StrataFrame Forum

Win 10 New UpDate

By Buffie - 12/9/2015

I let Win 10 update (huge-more like a reinstall) yesterday on 3 machines. It Screwed up every Strataframe install on those 3 machines (2 on VS 2013 and 1 on VS 2015). The error is that it can not find files it needs.
So, I would like to know if anyone has had the same issue or if you have not updated you may wait to see how this all washes out. Also, if you had the issue how did you resolve it.
By StrataFrame Team - 12/9/2015

I haven't done an upgrade where StrataFrame was in place.  Nor have I been able to update a computer to Windows 10.  Both computers I have tried to update have had a required Windows update package file to install.  KB-something-or-other on each one.  The same issue prevented me from installing VS2015 on those machines, so I had to reformat them and start over from scratch.

That being said, there are registry keys that are used by VS to locate the assemblies for extensions, and the location of those assemblies varies by VS version and .NET version.  Re-installing StrataFrame might help.  Have you tried that?
By Ivan George Borges - 12/9/2015

Yep, went through all these updates, including the last big one updating the already updated Win 10.

To get StrataFrame back, I reinstalled it. All fine.
By Buffie - 12/9/2015

Thanks for the quick response. 
I have not done re-installs yet. I am about ready to begin that. Will let you know how that goes.
By Edhy Rijo - 12/9/2015

Hi all,

Like Ivan and Ben suggest, reinstall SF does the trick, but in some cases is not only SF that got messed up, I had to re-install some other programs like MS SQL Server too. BigGrin

It looks like these Windows 10 updates refreshes or cleanup the GAC registry keys causing this kind of issues.  At least I have only seen this with my development computer, all my customers running Windows 10 my installed applications continue to work just fine, probably because I don't use the GAC for my assemblies, I install everything on the application folder.
By Buffie - 12/9/2015

Uninstalls and Re-installs on VS 2013 is all that was required. I will attack the VS 2015 later.
By Buffie - 12/9/2015

Uninstall and Reinstall on VS 2015 using instructions found here previously worked. 
Again thanks for the help.
By Edhy Rijo - 12/9/2015

Great!!!! good luck!