Server Times Out


Author
Message
Marcel Heitlager
Marcel Heitlager
StrataFrame Novice (84 reputation)StrataFrame Novice (84 reputation)StrataFrame Novice (84 reputation)StrataFrame Novice (84 reputation)StrataFrame Novice (84 reputation)StrataFrame Novice (84 reputation)StrataFrame Novice (84 reputation)StrataFrame Novice (84 reputation)StrataFrame Novice (84 reputation)
Group: StrataFrame Users
Posts: 84, Visits: 835
When trying to connect to ES it times out.  Also when I check status.aspx it says no clients have connected to this server.  It is in a directory that requires SSL connection.

The test form does a simple query:

'-- Build the Query
loSQLCmd.CommandText = "SELECT * FROM pws_Statements"

'-- Fill the business object using the command
me.FillDataTable(loSQLCmd)

The connection is as follows:

Dim ds As New EnterpriseDataSourceItem("", _
"www.aeswebaccess.com/aes/es", 443, "myKey", _
New SqlDataSourceItem(""))

'-- Configure the compression and encryption (optional)
ds.IsCompressed = True
ds.IsEncrypted = False
ds.EncryptionKey = New Byte() {1, 2, 3, 4, 5, 6, 7, 8, 9, 0, 1, 2, 3, 4, 5, 6, 7, 8, 9, 0, 1, 2, 3, 4}
ds.EncryptionVector =
New Byte() {1, 2, 3, 4, 5, 6, 7, 8}

'-- Add the EnterpriseDataSourceItem
DataLayer.DataSources.Add(ds)

I turned encryption off for testing.  "myKey" matches the key that status.aspx shows.  So does the host address.  The virtual directory is matches the physical path. Trying ports 80 and 8080 gives me an error, because it requires 443.

When I click submit it seems to send the query. Then my harddrive gets busy for a while and finally within about a minute it times out. (timeout is set at default)

I do have another oleDB connection that is on local drive to visual foxpro database that is handled through connection manager and has its own DataSourceKey.

Any thoughts on what I'm missing?  Could this be a problem with the connection string to the database? I made sure I have read/write permissions through NT AUTHORITY/Network account.  The connection string is:

<ConnectionString>server=MyServer\SQLEXPRESS;integrated security=SSPI;database=test_database</ConnectionString>

OK that's all I got! I'll shut up and listen now.Tongue

Marcel Heitlager
Marcel Heitlager
StrataFrame Novice (84 reputation)StrataFrame Novice (84 reputation)StrataFrame Novice (84 reputation)StrataFrame Novice (84 reputation)StrataFrame Novice (84 reputation)StrataFrame Novice (84 reputation)StrataFrame Novice (84 reputation)StrataFrame Novice (84 reputation)StrataFrame Novice (84 reputation)
Group: StrataFrame Users
Posts: 84, Visits: 835
Oh, one more thing.

I lifted the mac address from the server using ipconfig /all

I double checked it and seems to be correct.

OK, that it!Ermm I think.

Greg McGuffey
Greg McGuffey
Strategic Support Team Member (2K reputation)
Group: Forum Members
Posts: 2K, Visits: 6.6K
If a lot of data is returned by your test command, you might try limiting the data, using TOP (e.g. Select TOP 10....). If it returns, then you know you have a simple time out issue and need to figure out how to change that setting. I see nothing obviously wrong here (but then I'm no expert on the subtleties of ES)
Trent Taylor
Trent Taylor
StrataFrame Developer (6.6K reputation)StrataFrame Developer (6.6K reputation)StrataFrame Developer (6.6K reputation)StrataFrame Developer (6.6K reputation)StrataFrame Developer (6.6K reputation)StrataFrame Developer (6.6K reputation)StrataFrame Developer (6.6K reputation)StrataFrame Developer (6.6K reputation)StrataFrame Developer (6.6K reputation)
Group: StrataFrame Developers
Posts: 6.6K, Visits: 6.9K
One other thing to consider here is adjusting the timeout.  You can do this directly on the SqlCommand when you send it down the pipe as well as adjust the defaults on the server.  The first thing I would check would try would be setting the command timeout on the SqlCommand to get around this.  Also, like Greg mentioned, you may be pulling back more information that you need.  Also, if you are saving large amounts of data such as bitmaps, etc. then you could also use a Blob push (which is another thread and topic) to save this asynchrously.  There are a lot of options here, but before we dive into something more complex, just adjust the timeout on the SqlCommand and see if that resolves your issue. 
Marcel Heitlager
Marcel Heitlager
StrataFrame Novice (84 reputation)StrataFrame Novice (84 reputation)StrataFrame Novice (84 reputation)StrataFrame Novice (84 reputation)StrataFrame Novice (84 reputation)StrataFrame Novice (84 reputation)StrataFrame Novice (84 reputation)StrataFrame Novice (84 reputation)StrataFrame Novice (84 reputation)
Group: StrataFrame Users
Posts: 84, Visits: 835
Hi guys,

Thanks for the reply.  I adjusted the timeout on the SQLCommand to 360.

The error actually say "Operation timed out" when I execute the command.  Here's the the issue though.  I'm returning an empty dataset because the table is empty.  (eventually it might have 1000 records though that need to come back for processing).

Also when I run the routine, and check status.aspx, it never shows any unique clients connected or anything. When I attempt to connect to the ES, shouldn't it at least show somebody trying to connect? THe timeout on ES is like over a day now.  Could something be blocking the request?  All the websites over SSL work fine.

Any other ideas?

Trent Taylor
Trent Taylor
StrataFrame Developer (6.6K reputation)StrataFrame Developer (6.6K reputation)StrataFrame Developer (6.6K reputation)StrataFrame Developer (6.6K reputation)StrataFrame Developer (6.6K reputation)StrataFrame Developer (6.6K reputation)StrataFrame Developer (6.6K reputation)StrataFrame Developer (6.6K reputation)StrataFrame Developer (6.6K reputation)
Group: StrataFrame Developers
Posts: 6.6K, Visits: 6.9K
OK...so this has nothing to do with a query then...it sound smore like a connectivity issue.  At this point it sounds like you are not cnnecting to the ES web service then.  Once connected, you SHOULD see the MAC addresses of the connected clients.  So you might want to start digging around the IIS security permissions as well as any routers, firewalls, etc. that you have around the web server.
Marcel Heitlager
Marcel Heitlager
StrataFrame Novice (84 reputation)StrataFrame Novice (84 reputation)StrataFrame Novice (84 reputation)StrataFrame Novice (84 reputation)StrataFrame Novice (84 reputation)StrataFrame Novice (84 reputation)StrataFrame Novice (84 reputation)StrataFrame Novice (84 reputation)StrataFrame Novice (84 reputation)
Group: StrataFrame Users
Posts: 84, Visits: 835
I noticed at status.aspx under server name (site Name): it states Development SDK. Does that impact what I named the site?  Hostname says: www.aeswebaccess.com/aes/es

Also are the any web service extensions that need to be allowed?  I have ASP.NET v. 2.0.50727 allowed.  I thought the requests just went over HTTP or HTTPS.

I turned off windows firewall also with no luck.

I checked IIS security settings.  It requires 128 bit SSL connection.

 

Marcel Heitlager
Marcel Heitlager
StrataFrame Novice (84 reputation)StrataFrame Novice (84 reputation)StrataFrame Novice (84 reputation)StrataFrame Novice (84 reputation)StrataFrame Novice (84 reputation)StrataFrame Novice (84 reputation)StrataFrame Novice (84 reputation)StrataFrame Novice (84 reputation)StrataFrame Novice (84 reputation)
Group: StrataFrame Users
Posts: 84, Visits: 835
OK, I'm closer to a solution.

WHen I turned off SSL 128 bit for that site and changed to port 80, my mac address now shows when I make the request.

Now I just get a "The remote server returned an error: (500) Internal Server Error." message.  The stack trace is as follows:

   at System.Net.HttpWebRequest.GetResponse()
   at MicroFour.StrataFrame.Data.Enterprise.EnterpriseDataSourceItem.SendRequestCore(BaseParams Params, RemoteDataSourceCommand Command)
   at MicroFour.StrataFrame.Data.Enterprise.EnterpriseDataSourceItem.ᜀ(DbCommand A_0, Boolean A_1, String A_2)
   at MicroFour.StrataFrame.Data.Enterprise.EnterpriseDataSourceItem.GetDataTable(DbCommand Command, OnChangeEventHandler CallBack)
   at MicroFour.StrataFrame.Data.DataLayer.GetDataTable(DbCommand Command, Boolean RegisterNotification)

Still not quite there. But making progress (sloooooowly).

Marcel Heitlager
Marcel Heitlager
StrataFrame Novice (84 reputation)StrataFrame Novice (84 reputation)StrataFrame Novice (84 reputation)StrataFrame Novice (84 reputation)StrataFrame Novice (84 reputation)StrataFrame Novice (84 reputation)StrataFrame Novice (84 reputation)StrataFrame Novice (84 reputation)StrataFrame Novice (84 reputation)
Group: StrataFrame Users
Posts: 84, Visits: 835
The status on the error is: System.Net.WebExceptionStatus.ProtocolError
Trent Taylor
Trent Taylor
StrataFrame Developer (6.6K reputation)StrataFrame Developer (6.6K reputation)StrataFrame Developer (6.6K reputation)StrataFrame Developer (6.6K reputation)StrataFrame Developer (6.6K reputation)StrataFrame Developer (6.6K reputation)StrataFrame Developer (6.6K reputation)StrataFrame Developer (6.6K reputation)StrataFrame Developer (6.6K reputation)
Group: StrataFrame Developers
Posts: 6.6K, Visits: 6.9K
Still hard to give a direct answer at this point.  But one thing you may consider is turning on debugging for the data source to make sure that the query is properly formatted.  Next, (or maybe first) restart IIS to make sure that the application pool gets recycled.  To turn on debugging for a data source, do the following:

MicroFour.StrataFrame.Data.DataBasics.DataSources("").SetDebugOn(...)

GO

Merge Selected

Merge into selected topic...



Merge into merge target...



Merge into a specific topic ID...




Similar Topics

Reading This Topic

Login

Explore
Messages
Mentions
Search